Opened 5 years ago

Last modified 3 years ago

#909 new defect

Messagebot !quit

Reported by: shaddowknight Owned by:
Priority: normal Milestone: milestone:
Component: Bots - MessageBot Version: Latest version from repository
Severity: major Keywords:
Cc:

Description

Sir Shaddow <ER> here... this problem AGAIN
Made a channel for A Monk Seal today, got it set up, then !quit the channel.
And the bot removed me from all channels.
Ive made a ticket on this before with using !quit on a channel you are applied for (http://www.twcore.org/ticket/901), but !quit itself seems to be the issue.
Also, when I try to !join the channels again, it says I'm already on them, but I am not listed in !members for those channels, so I can't even reapply to them.

Change History (3)

comment:1 in reply to: ↑ description Changed 5 years ago by shaddowknight

Replying to shaddowknight:

Sir Shaddow <ER> here... this problem AGAIN
Made a channel for A Monk Seal today, got it set up, then !quit the channel.
And the bot removed me from all channels.
Ive made a ticket on this before with using !quit on a channel you are applied for (http://www.twcore.org/ticket/901), but !quit itself seems to be the issue.
Also, when I try to !join the channels again, it says I'm already on them, but I am not listed in !members for those channels, so I can't even reapply to them.

on another note, Since the bot still says I'm on those channels, I still get messages from them

comment:2 Changed 4 years ago by Trancid

Possibly fixed by Kane's commit in revision #7372?

comment:3 Changed 3 years ago by Trancid

Going to check soon if this problem still exists. If I cannot reproduce it, then I'll probably close this ticket as fixed.

Note: See TracTickets for help on using tickets.